New CloudPets Apps Available

New CloudPets Apps Available

Mar 24, 2017
Last week we launched brand new versions of the CloudPets apps for both iOS and Android.  These new versions launched with a brand-new setup process that makes it easier to get started with your CloudPet than ever before.  They also fixed a few bugs our users reported in the last version of the app, and paved the way for new functionality in future versions of the apps. Download the Apps en_app_rgb_wo_45 badge-download-on-the-app-store   Is My Smartphone or Tablet Compatible? This is a question we get quite a bit.  CloudPets require either iOS version 7.1 or later or Android 4.4.0 or later.  They also require that your device have Bluetooth 4.0 (Smart). You can view the full list of devices we’ve tested with CloudPets here.  If your smartphone or tablet is on that list, you’re good to go. If your smartphone or tablet isn’t on that list, but you’re sure it has Bluetooth Smart and a compatible OS, then it might work with CloudPets, but we can’t promise.  We’re regularly testing new devices with CloudPets, and will update our compatibility page as new devices are confirmed and tested.